Jump to content
Kieran_

PC Upgrade

Recommended Posts

After about 4 hours of trouble shooting a boot issue with windows (Old BIOS version issue) I finally got my machine working again with a new CPU and MOBO. (Still get 30FPS at Kav square)

Specs:
CPU: I9 9900K @ 4.8Ghz
CPU Cooling: H100i V2
RAM: 32GB DDR4 @ 3000Mhz
GPU: GTX 1080TI Strix OC edition
HDD: 2TB WD Black
HDD: 2TB Seagate Barracuda (It's from 2013 and fucking slower than a floppy)
HDD: 2TB Seagate Barracuda (A faster one)
SSD: 250GB Samsung
NVME: 500GB Samsung
MOBO: MPG Z390 MSI gaming Pro Carbon
CASE: Some unknown brand of case
OS: Windows 10 Home 64Bit
RGB: Corsair RGB RAM

Peripherals:
Monitor 1: AOC E2250SWDNK
Monitor 2: Acer XB271HU 144HZ 1440P (IPS version)
Monitor 3: AOC E2250SWDNK
Monitor 4: 40Inch TV
Mouse: Razer Mamba Tournament Edition
Keyboard: Corsair K70 (Brown Switches)
Headset: Astro A40 TR + MixAmp Pro
Microphone: Blue Snowball

 

Share this post


Link to post
Share on other sites
1 hour ago, Kieran_ said:

Monitor 1: AOC E2250SWDNK
Monitor 2: Acer XB271HU 144HZ 1440P (IPS version)
Monitor 3: AOC E2250SWDNK
Monitor 4: 40Inch TV

What's your reason behind 4 monitors, especially when one is a TV?

 

Edited by Luke.

Share this post


Link to post
Share on other sites

Once you go 4 you dont go back, I always keep task manager and other hardware monitoring open all the time, My GPU whist at the desktop with several programs open is currently at about 1% usage, It was my CPU that was always strained by my multiple applications so i needed an upgrade. I did however use wallpaper engine in the past that used around 7% at the desktop and did impact my games quite a bit so I stopped using it. @Luke.

Edited by Kieran_

Share this post


Link to post
Share on other sites
1 minute ago, Luke. said:

So please tell me you don't actually still get 30fps in Kav

Yeah it was massive over exaggeration, Arma overall is a horribly optimised game though I get like 110FPS when there isnt much going on in a single player enviroment but servers have issues with FPS due to the player counts and other stuff.

Share this post


Link to post
Share on other sites
6 minutes ago, Kieran_ said:

Yeah it was massive over exaggeration, Arma overall is a horribly optimised game though I get like 110FPS when there isnt much going on in a single player enviroment but servers have issues with FPS due to the player counts and other stuff.

Thought / was hoping so.

 

1 hour ago, Kieran_ said:

After about 4 hours of trouble shooting a boot issue with windows (Old BIOS version issue)

Did you previously have Windows 7 before upgrading?

 

And nice build👍

Edited by Luke.

Share this post


Link to post
Share on other sites

Nah I had windows 10 since it released just about, The Motherboard had an old BIOS on it that just refused to boot windows it kept freezing a few seconds after it started loading, Until I got the new BIOS flashed then it worked. @Luke.

Edited by Kieran_
ffs I keep forgetting to use quotes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.